Back to overview
Downtime

POP3 texelhosting.email:995, IMAP texelhosting.email:993, and 1 other service are down

Oct 04 at 06:47pm CEST
Affected services
POP3 texelhosting.email:995
IMAP texelhosting.email:993
SMTP texelhosting.email:465

Resolved
Oct 04 at 06:51pm CEST

SMTP texelhosting.email:465 recovered.

Updated
Oct 04 at 06:51pm CEST

POP3 texelhosting.email:995 and IMAP texelhosting.email:993 recovered.

Created
Oct 04 at 06:47pm CEST

POP3 texelhosting.email:995, IMAP texelhosting.email:993, and SMTP texelhosting.email:465 went down.