Back to overview
Downtime

POP3 texelhosting.email:995, IMAP texelhosting.email:993, SMTP texelhosting.email:465, and 1 other service are down

Dec 20 at 03:39pm CET
Affected services
POP3 texelhosting.email:995
IMAP texelhosting.email:993
SMTP texelhosting.email:465

Resolved
Dec 20 at 03:58pm CET

IMAP texelhosting.email:993 and SMTP texelhosting.email:465 recovered.

Updated
Dec 20 at 03:58pm CET

POP3 texelhosting.email:995 recovered.

Created
Dec 20 at 03:39pm CET

POP3 texelhosting.email:995, IMAP texelhosting.email:993, and SMTP texelhosting.email:465 went down.